SQL 2012 and older versions of Sitecore

So I just wanted to share something.  I have a client who is using 6.2 and SQL 2005.   They want to upgrade to 6.5.  They have SQL 2005 and SQL 2012.  Sitecore officially says that SQL 2012 is not supported for versions less than 6.5.  The option of moving to SQL 2008 , performing the upgrade, and then moving to SQL 2012 was less than fun to consider.  Instead, I tried doing a Sitecore 6.2 install, attaching the 6.2 databases to my SQL 2012 server.  Worked like a charm.  I’d say that for a short term “need to upgrade and don’t want to waste time with 2008” scenario  you can go ahead and try attaching your databases to SQL 2012 and doing the upgrade.  I have yet to do the actual upgrade, but I suspect that it should go just fine.

 

2 thoughts on “SQL 2012 and older versions of Sitecore

  1. We recently did a migration to a new set of web and SQL servers, so I mirrored our SQL 2008 R2 over to a new SQL 2012 (SiteCore 6.3).

    Stopped the mirror, Recovered the databases and brought the webservers online. No issues.

    Like

  2. We’re looking to migrate oracle to SQL Server 2012 on our Sitecore 6.3 CMS as a first step to upgrading to Sitecore 7.2. Did you experience any problems with running pre-6.5 CMS against SQL 2012?

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s